<html xml:lang="en-en" xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>
intoDNS: sanjosep.xyz - check DNS server and mail server health
</title>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
<meta content="intoDNS: Checking health and configurtion of DNS server and mail server for domainsanjosep.xyz." name="description">
<meta content="Elvsoft" name="author">
<meta content="intodns, dns server, mail server, dns reporting, dns report, dns checks" name="keywords">
<link href="/static/style/style.css" rel="stylesheet" type="text/css">
<link href="/static/style/thickbox.css" rel="stylesheet" type="text/css">
<link href="/static/images/favicon.ico" rel="shortcut icon" type="image/ico">
<script src="/static/js/jquery.js" type="text/javascript">
</script>
<script src="/static/js/hint.js" type="text/javascript">
</script>
<script src="/static/js/thickbox.js" type="text/javascript">
</script>
<script src="/static/js/onload.js" type="text/javascript">
</script>
</head>
<body>
<div id="master">
<div class="header">
<div id="logo">
<a href="/">
<img alt="intoDNS" src="/static/images/intodns_logo.gif">
</a>
</div>
<div class="report">
<form action="/check/" method="get">
<input class="inps" name="domain" type="text" value="sanjosep.xyz">
<input class="inpBtn" type="submit" value="Report">
</form>
</div>
</div>
<p>
</p>
<center>
<strong>
Work in progress!
</strong>
</center>
<p>
</p>
<p>
</p>
<center>
Follow IntoDNS on
<a href="https://twitter.com/intodns">
Twitter
</a>
<center>
<p>
</p>
<br>
<div class="content">
<table cellspacing="1" class="tabular" width="99%">
<thead>
<tr>
<th scope="col">
Category
</th>
<th scope="col">
Status
</th>
<th scope="col">
Test name
</th>
<th scope="col">
Information
<a class="thickbox feedback" href="feedback/?KeepThis=true&TB_iframe=true&height=300&width=240" title="intoDNS feedback">
send feedback
</a>
</th>
</tr>
</thead>
<tbody>
<!-- Parent Checks start -->
<tr>
<td rowspan="5" scope="row" style="vertical-align: top;">
Parent
</td>
<td class="icon">
<img alt="Info" src="/static/images/info.gif">
</td>
<td>
Domain NS records
</td>
<td>
Nameserver records returned by the parent servers are:
<br>
<br>
ns5.afternic.com.
['97.74.99.66'] (NO GLUE)
[TTL=3600]
<br>
ns6.afternic.com.
['173.201.67.66'] (NO GLUE)
[TTL=3600]
<br>
verification-gakbzzzqmt6gkcplw4efpp.ns123.verify.hn.
['13.248.169.48', '76.223.54.146'] (NO GLUE)
[TTL=3600]
<br>
<br>
<strong>
z.nic.xyz
</strong>
was kind enough to give us that information.
<br>
<br>
<p>
<a href="https://intovps.com/?utm_source=intodns&utm_medium=domainreport" id="banner1" style="display: none;" target="_blank" title="VPS hosting">
<img alt="VPS hosting - IntoVPS" src="/static/images/intovps.png">
</a>
<a href="https://hosterion.com/?utm_source=intodns&utm_medium=domainreport" id="banner2" style="display: none;" target="_blank" title="web hosting">
<img alt="Web hosting - Hosterion" src="/static/images/hosterion.png">
</a>
</p>
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
TLD Parent Check
</td>
<td>
Good. z.nic.xyz, the parent server I interrogated, has information for your TLD. This is a good thing as there are some other domain extensions like "co.us" for example that are missing a direct check.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
Your nameservers are listed
</td>
<td>
Good. The parent server z.nic.xyz has your nameservers listed. This is a must if you want to be found as anyone that does not know your DNS servers will first ask the parent nameservers.
</td>
</tr>
<tr class="icon">
<td class="icon">
<img alt="Info" src="/static/images/info.gif">
</td>
<td>
DNS Parent sent Glue
</td>
<td>
The parent nameserver z.nic.xyz is not sending out GLUE for every nameservers listed, meaning he is sending out your nameservers host names without sending the A records of those nameservers. It's ok but you have to know that this will require an extra A lookup that can delay a little the connections to your site. This happens a lot if you have nameservers on different TLD (domain.com for example with nameserver ns.domain.org.)
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
Nameservers A records
</td>
<td>
Good. Every nameserver listed has A records. This is a must if you want to be found.
</td>
</tr>
<!-- Parent Checks end -->
<tr>
<td class="static" rowspan="18" scope="row" style="vertical-align: top;">
NS
</td>
<td class="icon">
<img alt="Info" src="../static/images/info.gif">
</td>
<td>
NS records from your nameservers
</td>
<td>
NS records got from your nameservers listed at the parent NS are:
<br>
<br>
ns5.afternic.com ['97.74.99.66']
[TTL=3600]
<br>
ns6.afternic.com ['173.201.67.66']
[TTL=3600]
<br>
<br>
</td>
</tr>
<tr class="error">
<td class="icon">
<img alt="Error" src="../static/images/error.gif">
</td>
<td>
Recursive Queries
</td>
<td>
I could use the nameservers listed below to performe recursive queries. It may be that I am wrong but the chances of that are low. You should not have nameservers that allow recursive queries as this will allow almost anyone to use your nameservers and can cause problems. Problem record(s) are:
<br>
<strong>
173.201.67.66
</strong>
<br>
<strong>
97.74.99.66
</strong>
<br>
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Same Glue
</td>
<td>
The A records (the GLUE) got from the parent zone check are the same as the ones got from your nameservers. You have to make sure your parent server has the same NS records for your zone as you do according to the RFC. This tests only nameservers that are common at the parent and at your nameservers. If there are any missing or stealth nameservers you should see them below!
</td>
</tr>
<tr class="info">
<td class="icon">
<img alt="Information" src="../static/images/info.gif">
</td>
<td>
Glue for NS records
</td>
<td>
INFO: GLUE was not sent when I asked your nameservers for your NS records.This is ok but you should know that in this case an extra A record lookup is required in order to get the IPs of your NS records. The nameservers without glue are:
<br>
<strong>
173.201.67.66
</strong>
<br>
<strong>
97.74.99.66
</strong>
<br>
You can fix this for example by adding A records to your nameservers for the zones listed above.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Mismatched NS records
</td>
<td>
OK. The NS records at all your nameservers are identical.
</td>
</tr>
<tr class="error">
<td class="icon">
<img alt="Error" src="../static/images/error.gif">
</td>
<td>
DNS servers responded
</td>
<td>
ERROR: One or more of your nameservers did not respond:
<br>
The ones that did not respond are:
<br>
<strong>
76.223.54.146
</strong>
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Name of nameservers are valid
</td>
<td>
OK. All of the NS records that your nameservers report seem valid.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Multiple Nameservers
</td>
<td>
Good. You have multiple nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Nameservers are lame
</td>
<td>
OK. All the nameservers listed at the parent servers answer authoritatively for your domain.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Missing nameservers reported by parent
</td>
<td>
OK. All NS records are the same at the parent and at your nameservers.
</td>
</tr>
<tr class="error">
<td class="icon">
<img alt="Error" src="../static/images/error.gif">
</td>
<td>
Missing nameservers reported by your nameservers
</td>
<td>
ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are:
<br>
<strong>
verification-gakbzzzqmt6gkcplw4efpp.ns123.verify.hn
</strong>
<br>
This is listed as an ERROR because there are some cases where nasty problems can occur (if the TTLs vary from the NS records at the root servers and the NS records point to your own domain, for example).
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Domain CNAMEs
</td>
<td>
OK. RFC1912 2.4 and RFC2181 10.3 state that there should be no CNAMEs if an NS (or any other) record is present.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
NSs CNAME check
</td>
<td>
OK. RFC1912 2.4 and RFC2181 10.3 state that there should be no CNAMEs if an NS (or any other) record is present.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Different subnets
</td>
<td>
OK. Looks like you have nameservers on different subnets!
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
IPs of nameservers are public
</td>
<td>
Ok. Looks like the IP addresses of your nameservers are public. This is a good thing because it will prevent DNS delays and other problems like
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
DNS servers allow TCP connection
</td>
<td>
OK. Seems all your DNS servers allow TCP connections. This is a good thing and useful even if UDP connections are used by default.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Different autonomous systems
</td>
<td>
OK. It seems you are safe from a single point of failure. You must be careful about this and try to have nameservers on different locations as it can prevent a lot of problems if one nameserver goes down.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="../static/images/pass.gif">
</td>
<td>
Stealth NS records sent
</td>
<td>
Ok. No stealth ns records are sent
</td>
</tr>
<!-- NS Checks start -->
<!-- SOA Checks -->
<tr>
<td class="static" rowspan="8" scope="row" style="vertical-align: top;">
SOA
</td>
<td class="icon">
<img alt="Info" src="/static/images/info.gif">
</td>
<td>
SOA record
</td>
<td>
The SOA record is:
<br>
Primary nameserver:
<strong>
ns5.afternic.com
</strong>
<br>
Hostmaster E-mail address:
<strong>
dns.jomax.net
</strong>
<br>
Serial #:
<strong>
2025093000
</strong>
<br>
Refresh:
<strong>
28800
</strong>
<br>
Retry:
<strong>
7200
</strong>
<br>
Expire:
<strong>
604800 1 weeks
</strong>
<br>
Default TTL:
<strong>
300
</strong>
<br>
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
NSs have same SOA serial
</td>
<td>
OK. All your nameservers agree that your SOA serial number is
<strong>
2025093000
</strong>
.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
SOA MNAME entry
</td>
<td>
OK.
<strong>
ns5.afternic.com
</strong>
That server is listed at the parent servers.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
SOA Serial
</td>
<td>
Your SOA serial number is:
<strong>
2025093000
</strong>
.
This appears to be in the recommended format of YYYYMMDDnn.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
SOA REFRESH
</td>
<td>
OK. Your SOA REFRESH interval is:
<strong>
28800
</strong>
. That is OK
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
SOA RETRY
</td>
<td>
Your SOA RETRY value is:
<strong>
7200
</strong>
. Looks ok
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
SOA EXPIRE
</td>
<td>
Your SOA EXPIRE number is:
<strong>
604800
</strong>
.Looks ok
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
SOA MINIMUM TTL
</td>
<td>
Your SOA MINIMUM TTL is:
<strong>
300
</strong>
. This value was used to serve as a default TTL for records without a given TTL value and now is used for negative caching (indicates how long a resolver may
cache the negative answer). RFC2308 recommends a value of 1-3 hours. Your value of
<strong>
300
</strong>
is OK.
</td>
</tr>
<!-- MX Checks -->
<tr>
<td rowspan="11" scope="row" style="vertical-align: top;">
MX
</td>
<td class="icon">
<img alt="Info" src="/static/images/info.gif">
</td>
<td>
MX Records
</td>
<td>
Your MX records that were reported by your nameservers are:
<br>
<br>
0
No A Record (no glue either)
<br>
<br>
[These are all the MX records that I found. If there are some non common MX records at your nameservers you should see them below. ]
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
Different MX records at nameservers
</td>
<td>
Good. Looks like all your nameservers have the same set of MX records. This tests to see if there are
any MX records not reported by all your nameservers and also MX records that have the same hostname but different IPs
</td>
</tr>
<tr class="error">
<td class="icon">
<img alt="Error" src="/static/images/error.gif">
</td>
<td>
MX name validity
</td>
<td>
The MX records that do not seem valid hostname:
<br>
<strong>
</strong>
<br>
This can cause problems
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
MX IPs are public
</td>
<td>
OK. All of your MX records appear to use public IPs.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
MX CNAME Check
</td>
<td>
OK. No problems here.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
MX A request returns CNAME
</td>
<td>
OK. No CNAMEs returned for A records lookups.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
MX is not IP
</td>
<td>
OK. All of your MX records are host names.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Info" src="/static/images/info.gif">
</td>
<td>
Number of MX records
</td>
<td>
OK. Looks like you only have one MX record at your nameservers. You should be careful about what you are doing since you have a single point of failure that can lead to mail being lost if the server is down for a long time.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
Mismatched MX A
</td>
<td>
OK. I did not detect differing IPs for your MX records.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
Duplicate MX A records
</td>
<td>
OK. I have not found duplicate IP(s) for your MX records. This is a good thing.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
Reverse MX A records (PTR)
</td>
<td>
Your reverse (PTR) record:
<br>
You have reverse (PTR) records for all your IPs, that is a good thing.
</td>
</tr>
<!-- SMTP Checks -->
<!-- WWW Checks -->
<tr class="Info">
<td rowspan="3" scope="row" style="vertical-align: top; background-color: #ffffff;">
WWW
</td>
<td class="icon">
<img alt="Info" src="/static/images/info.gif">
</td>
<td>
WWW A Record
</td>
<td>
Your www.sanjosep.xyz A record is:
<br>
www.sanjosep.xyz
[13.248.169.48]
[76.223.54.146]
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
IPs are public
</td>
<td>
OK. All of your WWW IPs appear to be public IPs.
</td>
</tr>
<tr>
<td class="icon">
<img alt="Pass" src="/static/images/pass.gif">
</td>
<td>
WWW CNAME
</td>
<td>
OK. No CNAME
</td>
</tr>
</tbody>
</table>
<p>
Processed in 9.089 seconds.
</p>
</div>
<div id="footer">
<div id="copyright">
©
<a href="https://hosterion.ro" title="Web hosting">
Hosterion - web hosting
</a>
|
<a href="http://www.intovps.com/" title="vps hosting">
VPS hosting
</a>
by IntoVPS
</div>
<div id="madewith">
Made with
<a href="https://www.python.org/">
Python
</a>
,
<a href="https://www.djangoproject.com/">
Django
</a>
&
<a href="http://jquery.com/">
jQuery
</a>
</div>
</div>
</center>
</center>
</div>
<script src="https://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "UA-2900375-1";
urchinTracker();
</script>
</body>
</html>